Answered

Can't "Create Product"... green button won't open the popup

I'm just trying to get started setting up my membership site, and I'm stumped already. The first thing the setup video says to do is create a product... and I can't even do that. The popup window tries to open then doesn't. I see the orange bar display for a split second, then nothing. I don't have popups blocked, as I can go to other pages like "Create a Member" and that successfully opens the popup window.


Any idea what could be wrong?


1 person has this question

This is really strange. I've tried uninstalling and reinstalling it but that didn't help. Does anyone have any ideas what could be the problem?



I just realized the same thing is happening in the "Bundles" section... I can't create a bundle either. Is there something I have to do or create first, before I'm allowed to create products or bundles?


I'm really hoping someone can answer me soon... I was hoping to setup my website this weekend :)


Cheers,

Rob.

Has no one else had this problem? Very frustrating. I'm about ready to give up on MM which is too bad as it really looked perfect for my business.

I actually just had this problem now. I reinstalled Member Mouse to fix something I did and can't create either a product or a bundle. I'm about to give up too. I can't have these glitches when I'm live.

I was told by MM support that the problem was on my end... the server I had MM installed on. After trying a bunch of things and trying to get my host to make changes, I gave up and ordered hosting from another provider, and setup a brand new account. I waited for DNS to propagate, and then installed MM in my new hosting account... and SAME THING!! MM won't let me create a product or a bundle.


So then I got to thinking, maybe MemberMouse doesn't work on VPS systems? So this morning I went with MM recommendation and bought a 3rd hosting plan, this time the GoGeek plan from SiteGround... changed my DNS, setup my WordPress site, installed MM... and GUESS WHAT?? Same thing. MM doesn't work. Is it me?? What could I be doing wrong?? Is the current build of MM that people are downloading corrupt?


This is so frustrating. As far as I can tell, MemberMouse just doesn't work. And they aren't willing to set it up for me.

Answer

Hi Rob/Lisa,


I've looked into this with our development team and discovered the source of the problem. This issue is a result of the collation used on your database tables which is set to utf8mb4_unicode_ci or something similar. The problem with this is that this particular collation style restricts the length of keys on the database tables resulting in certain MemberMouse tables failing to be installed during plugin activation. 


If you review your database error logs you will see these errors reflected like this:

WordPress database error: [Specified key was too long; max key length is 1000 bytes]


As you can imagine, when tables are missing from the database this will manifest in different ways depending on which tables are missing. In this case, you're experiencing a problem creating a product which is specifically the result of the mm_affiliate_providers table not being installed. However, when the utf8mb4_unicode_ci collation is used the following is the complete list of tables that won't be installed:


mm_affiliate_providers

mm_affiliate_rebill_commissions

mm_email_service_providers

mm_log_events

mm_social_login_linked_profiles

mm_stripe_customer_links


If you're just getting started and don't have any data in MemberMouse, or very little data, the easiest and safest way to address this is to do the following: 


1. Follow the steps to Uninstall MemberMouse.

2. Via phpMyAdmin, navigate to the database that's being used for your WordPress install. This is the database table listed in your wp-config.php file.

3. Set the default collation of the database to utf8_unicode_ci

4. Perform a fresh install of the MemberMouse plugin


Following this all of the MemberMouse tables will have been installed.


If you're interested, there's more information about this scenario in the following article:

http://support.membermouse.com/solution/articles/9000063367-wordpress-database-error-specified-key-was-too-long

Thank you Eric! All seems to be working now.

I had the same problem. The solution worked, but it temporarily blew up my site. Had to research how to manually disable a plug-in. Seems to be working now. Thanks.

My site crashed after following the instructions. I had to manually delete the MM plugin. Then do it all over again. I would suggest  deleting the Member Mouse Plug in, dropping the tables and setting the default collation of the database to utf8_unicode_ci and then reinstall the plugin... That worked great. 

Im having same problem, after following the instructions my site crashed and not only but also changed all the special characters of the site and lost some info in the widgets, but after making the reinstalation of the plugin and reubuilding the site this time wit the utf8_unicode_c .. still not works, everything else works ok :/ 


Login or Signup to post a comment