As part of MM 2.2.6 we've upgraded the PHP libraries associated with some of our 3rd party integrations to the latest versions. Collectively these libraries require that certain PHP extensions are installed on your hosting environment in order to function properly (namely cURLJSON, and Multibyte String). These extensions are usually standard on most hosting environments, but in some environments one of more of these extensions may be missing.

Additionally, you may have recently heard that most of the major payment gateway services supported by MemberMouse are preparing to start only accepting requests made using the TLS 1.2 encryption protocol. This is being driven by changes in the PCI-DSS Compliance specification made in response to recently discovered vulnerabilities in SSL and lower versions of TLS.

Prior to upgrading to MM 2.2.6 you'll need to ensure that your hosting environment has all the PHP extensions required by the 3rd party libraries bundled with MemberMouse and that TLS 1.2 is supported. To make this process easy for you, we've developed a WordPress plugin that will let you know if your environment meets all the requirements. Simply download the plugin by clicking the link below and install it like any WordPress plugin


Using the Compatibility Test Plugin

Once you've activated the plugin, click on the MM 2.2.6 Compatibility Test menu item in the left side navigation bar. If your environment is compatible with MemberMouse 2.2.6 you will see a screen like this:




If one or more of the tests fail, you'll see something like below. In this scenario you'll need to reach out to your hosting provider to have them update your environment prior to upgrading. 




Once you've run the test, it’s safe to deactivate and delete the compatibility plugin.