Landing Page/Front Page

Hi, One Of Clients Wanted A Front Page For His MemberMouse Site For His Visitors/Non Members. I Created The Page But We Are Receiving An Issue That The Page I Created Don't Show Any Content To The Visitors When I Make It The Front Page Of The Site It Only Shows A Blank Page With Header And Footer While When It's Not Set To The Front Page All The Content Shows Well And The Members Logged In Of Course Gets Redirected To Their Member Pages Associated With Their Subscription So That Works Fine Now I Want To Know How Can I Make That Page(Which I Made) Visible To Visitors/Non Members?
Please Explain With Details Cause I Don't Have Any Experience With MM.
And The Landing Page Is Created In WPBakery.
I Have Played Around With The 
Member Homepage Settings But They Don't Same To Working.

Hi Yasir, 


Thank you for reaching out to MemberMouse!  It sounds from your description as though the page in question is set as the site front page in WordPress, and is not protected by MemberMouse.  MemberMouse doesn't influence pages that are not either created by MemberMouse as a Core Page, or explicitly setup to use MemberMouse Content Protection, and under most circumstances you would not want your site front page to be set as either. 


If you don't see any access right types (membership levels or bundles), or core page types set in the MemberMouse Options box of the WordPress page editor, that means it is not being protected or affected by MemberMouse.  If this is the case, I would suggest reaching out to WordPress Bakery, since they created the editor you are using for your page content.


If you do see protections added to the page, you can click the red trash can icon next to each line to remove them.  This will allow both members and non-members to access the page. 


Here is the MemberMouse Options section view without any page protection or core page associations added.  In the standard TinyMCE editor (WP 4.9 and under), this will be at the top of the right hand sidebar.  In Gutenberg (WP 5.0 and above) It will be at the bottom of the Documents tab in the right hand sidebar:



ok so here's what I have done I changed this MM Preview Setting To Non-Members And Also Set The Page Front Page In WordPress But It Did Worked Then I Removed From WordPress Front Page And Guess What It Still Didn't Worked.


Hi, I add change the MM preview settings of this page to Non-Members and also set it as WP Front Page and it didn't work then i removed it from WP front page and guess what it still didn't work. :)



Login or Signup to post a comment