Updated August 19, 2019


Yes. MemberMouse takes very seriously the responsibility to implement security and infrastructure updates for all the payment gateways that we support and we are working on making necessary changes in advance of the Revised Payment Services Directive (PSD2) which goes into effect September 14, 2019. There will be a new MemberMouse release and an update to the plugin will be necessary.


In brief, the main requirement of PSD2 as relates to online businesses is Strong Customer Authentication (SCA) - similar to what people refer to as two-factor authentication - which necessitates a 3D Secure (3DS) checkout flow for initial and one-time purchases where both the initiating and acquiring banks are both in the European Economic Area (EEA).


Our developers are working on an update to bring those payment integrations that fall under our purview (Stripe and Braintree) into compliance with the new SCA requirements by the September deadline. This includes providing support for 3D Secure 2.0. You can find information about additional integrations in the blog post listed below.


This is an ongoing project and any new developments or information will be added to this post - PSD2, Strong Customer Authentication and 3D Secure 2.0.  


If you would like to be added to our mailing list to receive updates, you can sign up using this form