TL;DR PHP 5.6 was released 7 years ago and made obsolete 3 years ago. Do not use this.



If you see a warning message like this on your site, you need to contact your hosting provider and request that they upgrade your server to PHP 7.x. We fully support PHP 7 and run it locally ourselves. In fact, PHP 7 seems to run MemberMouse twice as fast as PHP 5.6 with no other changes, and MemberMouse as of 2.2.5 picks up the strong cryptographic functions native to PHP 7 (which makes passwords, sessions, and API keys significantly stronger).


There are some hosts who will tell you that they can't upgrade you to PHP 7.x. These hosts must be avoided at all costs. It means that the hosting company doesn't care about investing the minimal amount of time required to properly set up their machines and ensure your security. 


If you need help choosing a new hosting provider, read our article on WordPress hosting providers.